WordPress and PHP versions matching

Today while I'm trying to deploy a new wordpress (latest version 5.2)  website in the server. I met an error message:

Your server is running PHP version 5.4.19 but WordPress 5.2 requires at least 5.6.20.

That means I need to upgrade PHP version or select older version of wp platform.

Here is the list of wordpress and php versions compactivity:

Historical PHP Requirements
5.2 PHP version 5.6.20 or greater.
5.1 PHP version 5.2.4 or greater.
5.0 PHP version 5.2.4 or greater.
4.9 PHP version 5.2.4 or greater.
4.8 PHP version 5.2.4 or greater.
4.7 PHP version 5.2.4 or greater.
4.6 PHP version 5.2.4 or greater.
4.5 PHP version 5.2.4 or greater.
4.4 PHP version 5.2.4 or greater.
4.3 PHP version 5.2.4 or greater.
4.2 PHP version 5.2.4 or greater.
4.1 PHP version 5.2.4 or greater.
4.0 PHP version 5.2.4 or greater.
3.9 PHP version 5.2.4 or greater.
3.8 PHP version 5.2.4 or greater.
3.7 PHP version 5.2.4 or greater.
3.6 PHP version 5.2.4 or greater.
3.5 PHP version 5.2.4 or greater.
3.4 PHP version 5.2.4 or greater.
3.3 PHP version 5.2.4 or greater.
3.2 PHP version 5.2.4 or greater.
3.1 PHP version 4.3 or greater.
3.0 PHP version 4.3 or greater.
2.9 PHP version 4.3 or greater.
2.8 PHP version 4.3 or greater.
2.7 PHP version 4.3 or greater.
2.6 PHP version 4.3 or greater.
2.5 PHP version 4.3 or greater.
2.3 PHP version 4.2 or greater.
2.2 PHP version 4.2 or greater.
2.1 PHP version 4.2 or greater.
2.0 PHP version 4.2 or greater.
1.5 PHP version 0 or greater.
1.2 PHP version 0 or greater.
1.0 PHP version 0 or greater.
0.7 PHP version 0 or greater.